Apache Commons logo Commons Weaver

Reactor Dependency Convergence

Legend:
[Error] At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of modules: 12
Number of dependencies (NOD): 51
Number of unique artifacts (NOA): 58
Number of version-conflicting artifacts (NOC): 5
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA): [Error] 87 %
Ready for release (100% convergence and no SNAPSHOTS): [Error] Error
You do not have 100% convergence.

Dependencies used in modules

org.apache.maven:maven-artifact

[Error]
3.0
  1. org.apache.commons:commons-weaver-maven-plugin:maven-plugin:1.4-SNAPSHOT
    \- org.apache.maven.plugin-tools:maven-plugin-annotations:jar:3.1:provided
       \- (org.apache.maven:maven-artifact:jar:3.0:provided - omitted for conflict with 3.1.0)

3.1.0
  1. org.apache.commons:commons-weaver-maven-plugin:maven-plugin:1.4-SNAPSHOT
    +- org.apache.maven:maven-plugin-api:jar:3.1.0:provided
    |  \- org.apache.maven:maven-artifact:jar:3.1.0:provided
    \- org.apache.maven:maven-core:jar:3.1.0:provided
       \- (org.apache.maven:maven-artifact:jar:3.1.0:provided - omitted for duplicate)

org.codehaus.plexus:plexus-classworlds

[Error]
2.4
  1. org.apache.commons:commons-weaver-maven-plugin:maven-plugin:1.4-SNAPSHOT
    \- org.apache.maven:maven-plugin-api:jar:3.1.0:provided
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.0.0.M2a:provided
          \- (org.codehaus.plexus:plexus-classworlds:jar:2.4:provided - omitted for conflict with 2.4.2)

2.4.2
  1. org.apache.commons:commons-weaver-maven-plugin:maven-plugin:1.4-SNAPSHOT
    \- org.apache.maven:maven-core:jar:3.1.0:provided
       \- org.codehaus.plexus:plexus-classworlds:jar:2.4.2:provided

org.codehaus.plexus:plexus-utils

[Error]
1.5.5
  1. org.apache.commons:commons-weaver-maven-plugin:maven-plugin:1.4-SNAPSHOT
    \- org.apache.maven:maven-core:jar:3.1.0:provided
       \- org.sonatype.plexus:plexus-sec-dispatcher:jar:1.3:provided
          \- (org.codehaus.plexus:plexus-utils:jar:1.5.5:provided - omitted for conflict with 3.0.10)

2.0.6
  1. org.apache.commons:commons-weaver-maven-plugin:maven-plugin:1.4-SNAPSHOT
    \- org.codehaus.plexus:plexus-utils:jar:2.0.6:compile

2.1
  1. org.apache.commons:commons-weaver-maven-plugin:maven-plugin:1.4-SNAPSHOT
    \- org.apache.maven:maven-plugin-api:jar:3.1.0:provided
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.0.0.M2a:provided
          \- (org.codehaus.plexus:plexus-utils:jar:2.1:provided - omitted for conflict with 3.0.10)

3.0.10
  1. org.apache.commons:commons-weaver-maven-plugin:maven-plugin:1.4-SNAPSHOT
    +- org.apache.maven:maven-plugin-api:jar:3.1.0:provided
    |  +- org.apache.maven:maven-model:jar:3.1.0:provided
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.10:provided - omitted for duplicate)
    |  \- org.apache.maven:maven-artifact:jar:3.1.0:provided
    |     \- (org.codehaus.plexus:plexus-utils:jar:3.0.10:provided - omitted for duplicate)
    \- org.apache.maven:maven-core:jar:3.1.0:provided
       +- org.apache.maven:maven-settings:jar:3.1.0:provided
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.10:provided - omitted for duplicate)
       +- org.apache.maven:maven-settings-builder:jar:3.1.0:provided
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.10:provided - omitted for duplicate)
       +- org.apache.maven:maven-repository-metadata:jar:3.1.0:provided
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.10:provided - omitted for duplicate)
       +- org.apache.maven:maven-model-builder:jar:3.1.0:provided
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.10:provided - omitted for duplicate)
       +- org.apache.maven:maven-aether-provider:jar:3.1.0:provided
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.10:provided - omitted for duplicate)
       \- (org.codehaus.plexus:plexus-utils:jar:3.0.10:provided - omitted for conflict with 2.0.6)

org.eclipse.aether:aether-api

[Error]
0.9.0.M2
  1. org.apache.commons:commons-weaver-maven-plugin:maven-plugin:1.4-SNAPSHOT
    \- org.apache.maven:maven-core:jar:3.1.0:provided
       +- org.apache.maven:maven-aether-provider:jar:3.1.0:provided
       |  +- (org.eclipse.aether:aether-api:jar:0.9.0.M2:provided - omitted for duplicate)
       |  \- org.eclipse.aether:aether-spi:jar:0.9.0.M2:provided
       |     \- (org.eclipse.aether:aether-api:jar:0.9.0.M2:provided - omitted for duplicate)
       +- org.eclipse.aether:aether-impl:jar:0.9.0.M2:provided
       |  \- (org.eclipse.aether:aether-api:jar:0.9.0.M2:provided - omitted for duplicate)
       \- (org.eclipse.aether:aether-api:jar:0.9.0.M2:provided - omitted for conflict with 1.1.0)

1.1.0
  1. org.apache.commons:commons-weaver-maven-plugin:maven-plugin:1.4-SNAPSHOT
    +- org.eclipse.aether:aether-api:jar:1.1.0:compile
    \- org.eclipse.aether:aether-util:jar:1.1.0:compile
       \- (org.eclipse.aether:aether-api:jar:1.1.0:compile - omitted for duplicate)

org.eclipse.aether:aether-util

[Error]
0.9.0.M2
  1. org.apache.commons:commons-weaver-maven-plugin:maven-plugin:1.4-SNAPSHOT
    \- org.apache.maven:maven-core:jar:3.1.0:provided
       +- org.apache.maven:maven-aether-provider:jar:3.1.0:provided
       |  \- (org.eclipse.aether:aether-util:jar:0.9.0.M2:provided - omitted for duplicate)
       +- org.eclipse.aether:aether-impl:jar:0.9.0.M2:provided
       |  \- (org.eclipse.aether:aether-util:jar:0.9.0.M2:provided - omitted for duplicate)
       \- (org.eclipse.aether:aether-util:jar:0.9.0.M2:provided - omitted for conflict with 1.1.0)

1.1.0
  1. org.apache.commons:commons-weaver-maven-plugin:maven-plugin:1.4-SNAPSHOT
    \- org.eclipse.aether:aether-util:jar:1.1.0:compile