Apache Commons logo Commons CLI

PMD Results

The following document contains the results of PMD 4.3.

Files

org/apache/commons/cli/AmbiguousOptionException.java

Violation Line
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\AmbiguousOptionException.java: Can't use generics unless running in JDK 1.5 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\AmbiguousOptionException.java: Can't use generics unless running in JDK 1.5 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\AmbiguousOptionException.java: Can't use generics unless running in JDK 1.5 mode! 0

org/apache/commons/cli/BasicParser.java

Violation Line
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\BasicParser.java: Can't use annotations when running in JDK 1.4 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\BasicParser.java: Can't use annotations when running in JDK 1.4 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\BasicParser.java: Can't use annotations when running in JDK 1.4 mode! 0

org/apache/commons/cli/CommandLine.java

Violation Line
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\CommandLine.java: Can't use generics unless running in JDK 1.5 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\CommandLine.java: Can't use generics unless running in JDK 1.5 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\CommandLine.java: Can't use generics unless running in JDK 1.5 mode! 0

org/apache/commons/cli/DefaultParser.java

Violation Line
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\DefaultParser.java: Can't use JDK 1.5 for loop syntax when running in JDK 1.4 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\DefaultParser.java: Can't use JDK 1.5 for loop syntax when running in JDK 1.4 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\DefaultParser.java: Can't use JDK 1.5 for loop syntax when running in JDK 1.4 mode! 0

org/apache/commons/cli/GnuParser.java

Violation Line
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\GnuParser.java: Can't use annotations when running in JDK 1.4 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\GnuParser.java: Can't use annotations when running in JDK 1.4 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\GnuParser.java: Can't use annotations when running in JDK 1.4 mode! 0

org/apache/commons/cli/HelpFormatter.java

Violation Line
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\HelpFormatter.java: Can't use annotations when running in JDK 1.4 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\HelpFormatter.java: Can't use annotations when running in JDK 1.4 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\HelpFormatter.java: Can't use annotations when running in JDK 1.4 mode! 0

org/apache/commons/cli/MissingOptionException.java

Violation Line
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\MissingOptionException.java: Can't use generics unless running in JDK 1.5 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\MissingOptionException.java: Can't use generics unless running in JDK 1.5 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\MissingOptionException.java: Can't use generics unless running in JDK 1.5 mode! 0

org/apache/commons/cli/Option.java

Violation Line
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\Option.java: Can't use generics unless running in JDK 1.5 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\Option.java: Can't use generics unless running in JDK 1.5 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\Option.java: Can't use generics unless running in JDK 1.5 mode! 0

org/apache/commons/cli/OptionBuilder.java

Violation Line
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\OptionBuilder.java: Can't use annotations when running in JDK 1.4 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\OptionBuilder.java: Can't use annotations when running in JDK 1.4 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\OptionBuilder.java: Can't use annotations when running in JDK 1.4 mode! 0

org/apache/commons/cli/OptionGroup.java

Violation Line
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\OptionGroup.java: Can't use generics unless running in JDK 1.5 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\OptionGroup.java: Can't use generics unless running in JDK 1.5 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\OptionGroup.java: Can't use generics unless running in JDK 1.5 mode! 0

org/apache/commons/cli/Options.java

Violation Line
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\Options.java: Can't use generics unless running in JDK 1.5 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\Options.java: Can't use generics unless running in JDK 1.5 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\Options.java: Can't use generics unless running in JDK 1.5 mode! 0

org/apache/commons/cli/OptionValidator.java

Violation Line
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\OptionValidator.java: Can't use JDK 1.5 for loop syntax when running in JDK 1.4 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\OptionValidator.java: Can't use JDK 1.5 for loop syntax when running in JDK 1.4 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\OptionValidator.java: Can't use JDK 1.5 for loop syntax when running in JDK 1.4 mode! 0

org/apache/commons/cli/Parser.java

Violation Line
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\Parser.java: Can't use annotations when running in JDK 1.4 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\Parser.java: Can't use annotations when running in JDK 1.4 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\Parser.java: Can't use annotations when running in JDK 1.4 mode! 0

org/apache/commons/cli/PatternOptionBuilder.java

Violation Line
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\PatternOptionBuilder.java: Can't use generics unless running in JDK 1.5 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\PatternOptionBuilder.java: Can't use generics unless running in JDK 1.5 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\PatternOptionBuilder.java: Can't use generics unless running in JDK 1.5 mode! 0

org/apache/commons/cli/PosixParser.java

Violation Line
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\PosixParser.java: Can't use annotations when running in JDK 1.4 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\PosixParser.java: Can't use annotations when running in JDK 1.4 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\PosixParser.java: Can't use annotations when running in JDK 1.4 mode! 0

org/apache/commons/cli/TypeHandler.java

Violation Line
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\TypeHandler.java: Can't use generics unless running in JDK 1.5 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\TypeHandler.java: Can't use generics unless running in JDK 1.5 mode! 0
Error while parsing C:\vcs\svn\apache\commons\trunks-proper\cli\src\main\java\org\apache\commons\cli\TypeHandler.java: Can't use generics unless running in JDK 1.5 mode! 0