Apache Commons logo Commons VFS

Reactor Dependency Convergence

Legend:
[Error]
At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of modules: 6
Number of dependencies (NOD): 263
Number of unique artifacts (NOA): 297
Number of version-conflicting artifacts (NOC): 8
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA):
[Error]
 88 %
Ready for release (100% convergence and no SNAPSHOTS):
[Error]
 Error
You do not have 100% convergence.

Dependencies used in modules

com.fasterxml.jackson.core:jackson-annotations

[Error]
2.10.3
  1. org.apache.commons:commons-vfs2-jackrabbit2:jar:2.8.0
    \- org.apache.commons:commons-vfs2:jar:2.8.0:compile
       \- org.apache.hadoop:hadoop-hdfs-client:jar:3.3.0:compile
          +- com.fasterxml.jackson.core:jackson-annotations:jar:2.10.3:compile
          \- com.fasterxml.jackson.core:jackson-databind:jar:2.10.3:compile
             \- (com.fasterxml.jackson.core:jackson-annotations:jar:2.10.3:compile - omitted for duplicate)

2.11.3
  1. org.apache.commons:commons-vfs2-jackrabbit2:jar:2.8.0
    \- org.apache.jackrabbit:jackrabbit-standalone-components:jar:2.21.5:test
       \- org.apache.tika:tika-parsers:jar:1.25:test
          \- (com.fasterxml.jackson.core:jackson-annotations:jar:2.11.3:test - omitted for conflict with 2.10.3)

com.fasterxml.jackson.core:jackson-databind

[Error]
2.10.3
  1. org.apache.commons:commons-vfs2-jackrabbit2:jar:2.8.0
    \- org.apache.commons:commons-vfs2:jar:2.8.0:compile
       \- org.apache.hadoop:hadoop-hdfs-client:jar:3.3.0:compile
          \- com.fasterxml.jackson.core:jackson-databind:jar:2.10.3:compile

2.11.3
  1. org.apache.commons:commons-vfs2-jackrabbit2:jar:2.8.0
    \- org.apache.jackrabbit:jackrabbit-standalone-components:jar:2.21.5:test
       \- org.apache.tika:tika-parsers:jar:1.25:test
          \- (com.fasterxml.jackson.core:jackson-databind:jar:2.11.3:test - omitted for conflict with 2.10.3)

com.nimbusds:nimbus-jose-jwt

[Error]
3.10
  1. org.apache.commons:commons-vfs2:jar:2.8.0
    \- org.apache.hadoop:hadoop-common:test-jar:tests:3.3.0:test
       \- org.apache.hadoop:hadoop-auth:jar:3.3.0:test
          \- org.apache.kerby:kerb-simplekdc:jar:1.0.1:test
             \- org.apache.kerby:kerb-client:jar:1.0.1:test
                \- org.apache.kerby:token-provider:jar:1.0.1:test
                   \- (com.nimbusds:nimbus-jose-jwt:jar:3.10:test - omitted for conflict with 7.9)

7.9
  1. org.apache.commons:commons-vfs2:jar:2.8.0
    \- org.apache.hadoop:hadoop-common:test-jar:tests:3.3.0:test
       \- org.apache.hadoop:hadoop-auth:jar:3.3.0:test
          \- com.nimbusds:nimbus-jose-jwt:jar:7.9:test

org.apache.commons:commons-vfs2

[Error]
2.1
  1. org.apache.commons:commons-vfs2:jar:2.8.0
    \- org.apache.hadoop:hadoop-common:test-jar:tests:3.3.0:test
       \- (org.apache.commons:commons-vfs2:jar:2.1:test - omitted for cycle)

2.8.0
  1. org.apache.commons:commons-vfs2:jar:2.8.0

org.apache.httpcomponents:httpcore

[Error]
4.4.13
  1. org.apache.commons:commons-vfs2-jackrabbit2:jar:2.8.0
    \- org.apache.httpcomponents:httpclient:jar:4.5.13:compile
       \- org.apache.httpcomponents:httpcore:jar:4.4.13:compile

  2. org.apache.commons:commons-vfs2:jar:2.8.0
    \- org.apache.httpcomponents:httpclient:jar:4.5.13:compile
       \- org.apache.httpcomponents:httpcore:jar:4.4.13:compile

4.4.14
  1. org.apache.commons:commons-vfs2-jackrabbit2:jar:2.8.0
    \- org.apache.jackrabbit:jackrabbit-webdav:jar:2.21.5:compile
       \- (org.apache.httpcomponents:httpcore:jar:4.4.14:compile - omitted for conflict with 4.4.13)

  2. org.apache.commons:commons-vfs2:jar:2.8.0
    \- org.apache.httpcomponents:httpcore-nio:jar:4.4.14:test
       \- (org.apache.httpcomponents:httpcore:jar:4.4.14:test - omitted for conflict with 4.4.13)

org.codehaus.jackson:jackson-core-asl

[Error]
1.9.13
  1. org.apache.commons:commons-vfs2:jar:2.8.0
    \- org.apache.hadoop:hadoop-common:test-jar:tests:3.3.0:test
       \- org.apache.avro:avro:jar:1.7.7:test
          \- (org.codehaus.jackson:jackson-core-asl:jar:1.9.13:test - omitted for conflict with 1.9.2)

1.9.2
  1. org.apache.commons:commons-vfs2:jar:2.8.0
    \- org.apache.hadoop:hadoop-common:test-jar:tests:3.3.0:test
       \- com.sun.jersey:jersey-json:jar:1.19:test
          +- org.codehaus.jackson:jackson-core-asl:jar:1.9.2:test
          +- org.codehaus.jackson:jackson-mapper-asl:jar:1.9.2:test
          |  \- (org.codehaus.jackson:jackson-core-asl:jar:1.9.2:test - omitted for duplicate)
          +- org.codehaus.jackson:jackson-jaxrs:jar:1.9.2:test
          |  \- (org.codehaus.jackson:jackson-core-asl:jar:1.9.2:test - omitted for duplicate)
          \- org.codehaus.jackson:jackson-xc:jar:1.9.2:test
             \- (org.codehaus.jackson:jackson-core-asl:jar:1.9.2:test - omitted for duplicate)

org.codehaus.jackson:jackson-mapper-asl

[Error]
1.9.13
  1. org.apache.commons:commons-vfs2:jar:2.8.0
    \- org.apache.hadoop:hadoop-common:test-jar:tests:3.3.0:test
       \- org.apache.avro:avro:jar:1.7.7:test
          \- (org.codehaus.jackson:jackson-mapper-asl:jar:1.9.13:test - omitted for conflict with 1.9.2)

1.9.2
  1. org.apache.commons:commons-vfs2:jar:2.8.0
    \- org.apache.hadoop:hadoop-common:test-jar:tests:3.3.0:test
       \- com.sun.jersey:jersey-json:jar:1.19:test
          +- org.codehaus.jackson:jackson-mapper-asl:jar:1.9.2:test
          +- org.codehaus.jackson:jackson-jaxrs:jar:1.9.2:test
          |  \- (org.codehaus.jackson:jackson-mapper-asl:jar:1.9.2:test - omitted for duplicate)
          \- org.codehaus.jackson:jackson-xc:jar:1.9.2:test
             \- (org.codehaus.jackson:jackson-mapper-asl:jar:1.9.2:test - omitted for duplicate)

org.slf4j:slf4j-api

[Error]
1.5.11
  1. org.apache.commons:commons-vfs2-jackrabbit1:jar:2.8.0
    \- org.slf4j:slf4j-api:jar:1.5.11:test (scope not updated to compile)

1.7.26
  1. org.apache.commons:commons-vfs2-jackrabbit1:jar:2.8.0
    +- org.apache.jackrabbit:jackrabbit-webdav:jar:1.6.5:compile
    |  \- (org.slf4j:slf4j-api:jar:1.7.26:compile - version managed from 1.5.3; omitted for conflict with 1.5.11)
    +- org.slf4j:slf4j-log4j12:jar:1.5.11:test
    |  \- (org.slf4j:slf4j-api:jar:1.7.26:test - version managed from 1.5.11; omitted for conflict with 1.5.11)
    \- org.slf4j:jcl-over-slf4j:jar:1.5.11:test
       \- (org.slf4j:slf4j-api:jar:1.7.26:test - version managed from 1.5.11; omitted for conflict with 1.5.11)